You are not logged in.

Dear visitor, welcome to Legend: Legacy of the Dragons Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Saturday, January 2nd 2021, 12:07am

I cant complete quest "Creation of the little people"

Current goal: Place the Bringer of Evil Skull, Old Fossil, Collected Mistletoe, Agate Dust and Black Ink on the fires, and then activate the pedestal. When the Elt Cube has been activated, return to the Gnome Spirit.

When i touch the fires nothing happens, i tryed 2 PC browser and 2 mobile, but cant complete this. :(

22

Monday, January 25th 2021, 5:20am

http://warofdragons.com/fight_info.php?f…37&server_id=10

same group, did damage, on fury... no eyes, no loots. why?

Posts: 38

Location: Turkey

Occupation: Ankara

  • Send private message

23

Wednesday, February 3rd 2021, 2:36pm

ESTATE

Mysterious statue of experience
Doesn't open in browser( ı've tried on opera and chrome) (html5)

It's working on client.

note: i am using mac that's why ı can't use client.
Always better :beer:

24

Wednesday, February 10th 2021, 2:07pm

achievement : Mapping the Suburb of O'Delvays

http://warofdragons.com/achievement_info.php?id=83

I suppose it's "Suburb of O'Delvays" in the description.

25

Wednesday, February 17th 2021, 2:30am

on page: http://warofdragons.com/info/library/ind…?obj=cat&id=192

Little Dragon Urchi greets February

What is happening during the event is of great interest to the inquisitive Dragon Urchi. Do not forget to talk to him and help in understanding the world of Faeo.



Quest accessible to warriors who have reached level 3.
Accessible: one time
Reward: Carved Heart x5

it's daily
hi let's meet in game and have some fun :]
please use Font size > 10 for better reading

26

Wednesday, February 17th 2021, 8:26am

I cannot login to my account, new membership is coming out.
hipokrat_835

Posts: 287

Location: The Astral Plane

  • Send private message

27

Tuesday, July 20th 2021, 5:37pm

Can my bow powers in combat like not show in polish?

28

Friday, August 6th 2021, 9:53am

Compass locations are not transfered correctly:
" You defeated all the beasts — it’s time to go back to Kari."
I click on underlined "Kari"->compass opens wih inserted text "Thistle Brushwood". Compass only knows "Thistles" same with "black gaar"

29

Tuesday, August 10th 2021, 2:04am

information portal link in the current events page for Fury of the Dragons has the wrong hyperlink.
I'll look that up...

30

Wednesday, August 18th 2021, 5:47am

When on August event you ask fisherman where you can get fry (for magmars) he tells you to go to human locations.

<a href="https://ibb.co/JpnWxK0">Here is screenshot</a>


If link doesn't open, here is what he says:

I am not usually willing to share all my secrets, but as you are an old friend. You can try and catch a golden fish in Jasmine Brushwood, Dead Cove, Freedom Steppe, Wolf Wasteland, in some water reservoirs in the Land of the Deceased and Alaveya Vista, in Grand Fort Port and in the lands of the Eldives you can find fry, oh and in those... what are they called, Isles of Smoky or Swirling Mist, and look in the waters of the Flaundins, you may get lucky... But remember what I said! It is impossible to catch a big fish, but the fry- that’s easy. Take the net I have given you and use it to get them out of the water. You might get lucky!

P.S: I see inserting links on forum doesn't work too.

31

Monday, August 23rd 2021, 1:59am

All my Shadow rune seals in my backpack have Russian descriptions now.

No idea when that happened. Likely in a technical update (that usually breaks more stuff than fixes :lol: )

For example;-
warofdragons.com/artifact_info.php?artifact_id=638834940
warofdragons.com/artifact_info.php?artifact_id=711839976
warofdragons.com/artifact_info.php?artifact_id=697838866
warofdragons.com/artifact_info.php?artifact_id=508909375

11/12 types I have in my backpack are in Russian so I can assume others I don't have yet are also likely broken!!! :wall:

32

Wednesday, August 25th 2021, 7:42pm

my level12 bow skills in fight not english, german language please fix it

33

Saturday, September 11th 2021, 5:50am

exchange auction pls fix

I wanna buy stuff example like battle art code, etc in exchange but recenty when you apply need to put what the class for that item, i dont know what class is that , before no need to put class just time the item and its appear. Hope its fix soon.

34

Friday, September 17th 2021, 10:16pm

New Application option at Exchange

Hello Admin,

Strange option happen here (please see the screenshot) - i have clear cashe etc. reset etc. but the lack of possibility to put and sack of food request is very strange.
I have tried all option but it is not appear.

Please see here: http://warofdragons.com/forum/index.php?…&threadID=37175
han asd has attached the following file:
  • temp.jpg (90.14 kB - 42 times downloaded - latest: Oct 3rd 2021, 7:21pm)

This post has been edited 1 times, last edit by "T-DeAdLY-J" (Sep 27th 2021, 10:24pm)


This post by "han asd" (Sunday, September 19th 2021, 11:08pm) has been deleted by user "T-DeAdLY-J" (Monday, September 27th 2021, 10:23pm) with the following reason: spam

This post "Lack of Sack of Food option for the exchange" by "han asd" (Monday, September 20th 2021, 10:01pm) has been deleted by user "T-DeAdLY-J" (Monday, September 27th 2021, 10:23pm) with the following reason: spam